Skocz do zawartości


Zdjęcie

[cms/forum] Instalacja systemu wymiany linków (SWL)


  • Zaloguj się, aby dodać odpowiedź
Brak odpowiedzi do tego tematu

#1 makensis

makensis

    Naczelny

  • 5035 postów

Napisano 01 03 2009 - 16:10

Systemy wymiany linków dostępne i popularne na rynku polskim:
-Rotacyjne *czyli wyświetlające losowo linki
E-Weblink
GotLink

-Stałe linki(zdrowsze, bardziej naturalne) *wyświetla na stałe linki przez jakiś czas
LinkMe - najpopularniejszy w miarę bezpieczny
LiveLink - dość mało śmieci w systemie
Linkorn - coraz słabiej wypada
LinkujPRO - słabnący, ale ktoś tam jeszcze moderuje strony
LinkPorn - LinkMe w wersji erotycznej, dużo SPAMu

Hybrydy * linki rotacyjne i stałe
SEO.NET - linki statyczne prawie nie wyświetla
EroPowerLink - erotyczne, link wyświetla się przez 24h!
PowerLink - normalne, link wyświetla się przez 24h!

Śmieci *niebezpieczne programy
Linkor - problemy z aktywacją..
Linki24.pl - SPAM i problemy z naliczaniem punktów

1. Rejestrujemy się w wybranym serwisie, następnie dodajemy nasze forum do listy serwisów na których będą wyświetlane linki
2. Ściągamy paczki plików, które potem rozpakowujemy i wrzucamy na serwer i ustawiamy odpowiednie atrybuty plików (666) zgodnie z instrukcją na stronie
3. Tworzymy plik php np. linki.php i go edytujemy:

Zgodnie z zaleceniem serwisu SWL wklejamy treść jaka powinna zostać dodana do pliku PHP, aby zainstalować system wymiany linków.
np. Linkme (plik README.txt)

Jeżeli pierwszy raz przeprowadzasz instalację:

W treści strony głównej oraz na podstronach należy wstawić kod:

<?php
include("44444444444.php");
echo @LinkMeShowLinks("", "", " - ", "<div style=\"text-align:center;margin:auto;\">", "</div>");
?>


czyli do pliku: linki.php wklejamy tylko:

<?php
		include("44444444444.php");
		echo @LinkMeShowLinks("", "", " - ", "<div style=\"text-align:center;margin:auto;\">", "</div>");
		?>

4. Wchodzimy do panelu ACP forum (panel administracyjny) następnie klikamy zakładkę: LOOK & FEEL, wybieramy skin i klikamy obok niego na pierwszą pozycję (Edit Board Header):
Dołączona grafika

5. Teraz dodajemy przed końcem </body> treść:

<!--exec.file='/home/ADRES_DO_SERWERA/public_html/linki.php'-->

Ścieżka do serwera może się różnić, zazwyczaj jest to /home/nazwa-konta/public_html/adres forum..
Jeśli nie wiesz jaką masz ścieżkę do serwera przypomnij sobie konfigurację obrazków dodawanych na forum lub poproś swojego hostingodawcy o podanie jej.

6. Zapisujemy zmiany klikając Save wrapper

7. Aktywujemy nasz serwis w systemie wymiany linków, robot sprawdzi czy linki pojawiają się na stronie po czym przekaże adres do moderacji lub po prostu już zaczniemy naliczać punkty.

8. Dodajemy własny serwis lub zaplecze do systemu wymiany linków np. klikając w zakładkę "Zarządzanie linkami".
PAMIĘTAJ SWL NIE SŁUŻY DO POZYCJONOWANIA TYLKO DO WSPOMAGANIA POZYCJONOWANIA!
Jeśli nie znasz się na pozycjonowaniu możesz po prostu sprzedawać punktu jakie uzyskasz w serwisie i otrzymane pieniądze zainwestować w reklamy czy też zakup płatnych linków.


UWAGI/PROBLEMY:
1. Kilka systemów linkujących w jednym forum/serwisie

Przechodzimy do punktu 3 i dodajemy kilka systemów wymiany linków, więc powinno pojawić się include/include_once conajmniej dwa razy! Jeśli nie wyświetlają się linki z obu systemów spróbuj skopiować kod do innego pliku np. linki2.php i dodać osobny kod w punktcie 5 odnoszący się do tego pliku, czyli np. /home/ADRES_DO_SERWERA/public_html/linki2.php

2. Podglądam zawartość pliku adresforum.pl/linki.php i widzę pustą stronę

Czasami w sekcji include należy podać adres pliku wraz z dostępem do serwera, czyli (5) /home/NAZWA_KONTA/public_html/...

3. Wyświetlają mi się linki po wpisaniu adresforum.pl/linki.php, ale nie widzę ich na forum

Wejdź na swoje forum, kliknij na Pokaż źródło(Ctrl+U) i zobacz czy w kodzie nie ma <--! exec.. Jeśli jest to znaczy, że serwer nie obsługuje tego polecenia. Większość hostingodawców nie widzi przeciwskazań w używaniu tego kodu, jeśli jednak masz z tym problemy napisz do niego z prośbą o aktywację funkcji exec na hostingu.

4. Wyświetlają mi się błędy na forum po instalacji systemu linkującego

Zamień instrukcję include na include_once w pliku linki.php.

Publikacja, wraz ze zmianami treści tylko za zgodą autora. Nie ponoszę odpowiedzialności za problemy wynikające z instalacji powyższych skryptów, ani też ich użytkowania.

  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych